Angular Compiler requires TypeScript >=3.4.0 and <3.5.0 but 3.5.3 was found instead error occurs when there is a version mismatch between the Angular compiler’s expected TypeScript version and the TypeScript version installed in your project.
The error also occurs when you have installed a newer version of TypeScript than the one supported by Angular.
The error suggests that the version of TypeScript installed in your project (3.5.3) is incompatible with the version required by the Angular Compiler. The Angular Compiler requires a TypeScript version between 3.4.0 and 3.5.0.
To fix the “Angular Compiler requires TypeScript >=3.4.0 and <3.5.0 but 3.5.3 was found instead” error, you need to downgrade TypeScript to a compatible version. For example, email@example.com will fix this error.
You can install firstname.lastname@example.org using the below command.
npm install email@example.com --save-dev
This command will install TypeScript version 3.4.0 as a development dependency in your project.
If you prefer to use TypeScript 3.5.0 instead, you can install it with this command:
npm install firstname.lastname@example.org --save-dev
After downgrading TypeScript, you should no longer see the error message and the Angular Compiler should work as expected.
Remember that the different versions of Angular may require different versions of TypeScript, so always check the compatibility of your installed packages when upgrading or downgrading.